Idling and Hesitation Issues and need help

Discussion of STOCK engines, cooling system, fuel system, exhaust systems.

Idling and Hesitation Issues and need help

Postby chrisj1989 » Wed May 10, 2017 1:28 am

So i have a 1990 Mark VII and i'm having some weird idle and throttle hesitation at idle and up to near full throttle. i originally took it to a shop and they said it was the intake gasket so $1100 later that was done, turns out it didn't fix anything. then they said the ECU was bad and that was replaced and no change.
ive tried a few things so far, new MAP sensor, EGR Valve, Alternator, Voltage Regulator, plugs and wires, and a new fuel filter and its still there.

i have noticed when i unhook the vacuum line off the MAP while running the engine dies right away, however when i unhook the vacuum lines off (one at a time) the EGR, Fuel Pressure Regulator, the vacuum solenoid closest to the firewall, the 2 vacuum solenoid's by the Voltage Regulator, and the one on the coolant line on the passengers side of the engine and i feel no suction or pressure coming from them. i have a feeling this isn't normal and might be hard to fix if this is it.

if anyone has any advice or may know whats wrong any help would be greatly appreciated.
User avatar
chrisj1989
REGISTERED USER
 
Posts: 3
Joined: Sun May 07, 2017 9:03 pm

Re: Idling and Hesitation Issues and need help

Postby GRANADOJL » Thu May 11, 2017 4:59 pm

Just curious, have you checked fuel related parts? Such as filter, injectors themselves to make sure they are not plugged up. I had a very similar issue and when I busted an oil pan gasket, I pulled out the engine and rebuilt my engine. I found a broken pintle cap on cylinder 8 that never triggered a CEL. the fuel blockage was messing up the fuel delivery on cylinder 8. I replaced them with the plastic injectors and never had issues since.

May or may not be the problem. But at the price of a $5 upper plenum gasket. it's worth pulling off the upper plenum and removing the injectors to make sure they are good to go.
1990 Lincoln Mark VII LSC SE 5.0l
1957 Ford F100 347 Stroker
2006 Ford Explorer 4.6l
User avatar
GRANADOJL
REGISTERED USER
 
Posts: 246
Joined: Thu May 21, 2009 5:39 am
Location: Phoenix, AZ

Re: Idling and Hesitation Issues and need help

Postby chrisj1989 » Sun May 28, 2017 12:13 am

well i had the filter replaced for fuel and it has 40PSI at the rail, the mechanic i took it to that did the intake gasket had checked and cleaned the injectors.

i put a MSD Distributor that i had in it before back in and had the timing set to 10 BTDC it runs different but still not good it will idle but has choppy acceleration all the way up and will idle lumpy at times. i was going to try a new TPS and EGR Position sensor.

im also still having the no vacuum issue on the passengers side but all the main ones on the firewall on drivers side have vacuum.
User avatar
chrisj1989
REGISTERED USER
 
Posts: 3
Joined: Sun May 07, 2017 9:03 pm


Return to Engine

Who is online

Users browsing this forum: No registered users and 3 guests