please help digital dash 85 continental

Discussion of STOCK TripMinderĀ®, audio, video, LED, capacitors, instrument clusters and controls, integrated circuitry and boards, low voltage, message center, resistors, speedometers, tachometers, transistors and systems.

please help digital dash 85 continental

Postby Tsangaris44 » Fri Apr 18, 2014 8:49 pm

Hello, My name is Chris. I found this site to possibly find some help with my Continental and possibly help others with my knowledge. I have searched for digital dash (instrument cluster) problems and have found an interesting post in which it showed how to benchtest a cluster from a later year (almost identical) and i had done so but to no avail. it seemed my cluster was bad but it had been rebuilt only 6 yers ago and has mostly been sitting since then. I have not switched the ignition switch but after bench testing to check if functional seems like it wouldnt matter. I intend to switch it out soon, as the plastic is disattaching itself from the metal, it will soon need the replacement. I have searched the internet and found barely one Video, Forum, Or Website for a how to on the digital dashes and even less owners of an 85 continental 5.0 I figure if there was a place it would be here. I also checked the capacitors in the dash and none have seemed to bubble or dome at the top. Im tryin my best to figure this one out some one of my fellow Lincolnites HELPP :shock: !!!

Sincerely, Chris
User avatar
Tsangaris44
REGISTERED USER
 
Posts: 4
Joined: Fri Apr 18, 2014 8:29 pm
Location: selden ny

Re: please help digital dash 85 continental

Postby mike9251578 » Fri Apr 18, 2014 9:35 pm

Hi Chris,

Not sure if this is much help because I don't have any experience with electronics. Paul Protos (polyscroll@hotmail.com) does a lot of electronics repairs for folks here on the club. You may want to contact him directly and see if he could repair it or give you some ideas.

Hope that helps!
Mike - Wichita, KS
91 LSC Current Red
07 Escape (Wife's car)
94 Ranger 4x4
07 Mustang GT
2012 Lincoln MKX
1979 Mustang Indy Pace Car


Previous:
90 Bill Blass
User avatar
mike9251578
CLUB MEMBER
 
Posts: 68
Joined: Fri Feb 14, 2014 9:48 pm
Location: Lincoln, Nebraska

Re: please help digital dash 85 continental

Postby Tsangaris44 » Sat Apr 19, 2014 11:56 am

Thanks mike I definitley will
User avatar
Tsangaris44
REGISTERED USER
 
Posts: 4
Joined: Fri Apr 18, 2014 8:29 pm
Location: selden ny

Re: please help digital dash 85 continental

Postby Traveler » Sat Apr 19, 2014 11:11 pm

I recently went through this. Same deal, my capacitors looked fine. I decided to try it because it costs like $10 at radio shack and a few minutes of my time.
As with you I did not see any bubble tops, any leakage, any signs of damage or failure.
Image

There are these 4
Image
this one
Image
and this one. This one is the main power to the board.
You take the readings off the side, the voltage doesn't matter as long as the capacitance is the same. Physical size doesn't matter either. Technology is smaller today.
Image

$10 at radio shack
Image

Desolder
You should do one at a time as polarity does matter on a capacitor.
Image

first 4 done
Image

I tested each one after I took them out and I did not find a bad one. You cannot test them while they are still on the board.

Then I did the main power supply capacitor.
Image

Upon removal I went to test the old one and found the stud missing. I thought, well I broke it off removing it from the board. So I tried to test it and it was dead.
YAY!
Image

That fixed my problem. So don't send it off for a couple Hundred, hell I will do it for $50
Image
User avatar
Traveler
REGISTERED USER
 
Posts: 29
Joined: Mon Jun 08, 2009 9:14 am

Re: please help digital dash 85 continental

Postby oldschool1 » Sun Apr 20, 2014 10:19 pm

Traveler,
Thank you for the write up and the pictures!
User avatar
oldschool1
CLUB MEMBER
 
Posts: 8844
Joined: Fri Dec 26, 2008 10:01 pm
Location: Primos, Pennsylvania USA

Re: please help digital dash 85 continental

Postby Tsangaris44 » Mon Apr 28, 2014 12:30 pm

Yes thank you very much i surrently have an auto electric guy looking at t as we speak he is checkig it out now for 50$ he said he couldnt guarantee that it will work but he definitely has a good record with auto elctric. if he cant make it work i will get your information as i need this to work asap thanx again
User avatar
Tsangaris44
REGISTERED USER
 
Posts: 4
Joined: Fri Apr 18, 2014 8:29 pm
Location: selden ny

Re: please help digital dash 85 continental

Postby lpjbird » Sun Jul 13, 2014 3:50 pm

Hello, it's been some time since I've been back to this site and I was also having speedo, odom and fuel gauge problems with my 85 Continental Base. I have done everything I was told might be the problem to no avail. This looks like it may be the fix, I don't know & I'm not sure I'm capable of doing this on my own. The three items I've mentioned above start flashing "ON & OFF" after it seems the car has warmed up quite a bit. They don't come on until I've been driving for a while or just letting it idle for 20 minutes or so. I noticed that it is not calculating the mileage or the speed but the fuel gauge seems accurate and the "DTE". With this information I've given does it sound like the capacitors are the problem? I hate to have to remove all the dash again to get at them but will if you feel this may be my problem. Ha,Ha, I've done it 2 0r 3 times now cleaning connections and so on so I know how to do it! Thanks Guys & Gals.

PS. My charging problems were all solved with the great suggestions I received here, Thanks
Image
JR Bondy; Is the proud owner of a 1985 Continental Base -w- 5.0
If I knew I was gonna live this long I would've taken better care of myself. (Bobby Lane)
User avatar
lpjbird
REGISTERED USER
 
Posts: 38
Joined: Sun May 05, 2013 10:37 am
Location: The Motor City/Metro Detroit


Return to Electronic

Who is online

Users browsing this forum: No registered users and 1 guest